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Preface

Audience and Purpose
This guide is intended for users charged with managing SnapServer appliances running GuardianOS 7.0 or 
higher, SnapCLOUD servers, or SnapScale nodes running RAINcloudOS on their network using SnapStorage 
Manager (SSM). It provides server tasks, tips on maximizing SSM functionality, and user scenarios. 
SnapStorage Manager is usually installed on a network computer in the same LAN as the SnapServers, 
SnapCLOUD servers, and SnapScale nodes it manages.

It is assumed that the administrator is familiar with the basic concepts and tasks of multi-system network 
administration.

Product Documentation and Software
The SnapStorage Manager product documentation is available at the Overland-Tandberg Knowledge Base:

https://community.sphere3d.com/community/documentation

The latest release of the SnapStorage Manager and other software is available online:

http://docs.overlandstorage.com/snapserver

Overland Technical Support
For warranty and general technical support information, see our Contact Us web page:

http://www.overlandstorage.com/company/contact-us/index.aspx

For information on contacting Overland-Tandberg Technical Support, see our Contact Support web page:

http://support.overlandstorage.com/support/contact.htm

To search for more service information, visit our Knowledge Bases:

https://community.sphere3d.com/welcome

Japanese Voluntary Control Council for Interference (VCCI)
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Conventions
This document exercises several alerts and typographical conventions.

Information contained in this guide has been reviewed for accuracy, but not for product warranty because of 
the various environments, operating systems, or settings involved. Information and specifications may change 
without notice.

Convention Description & Usage

WARNING 

WARNUNG

ADVERTISSEMENT

A Warning contains information concerning personal safety. Failure to 
follow directions in the Warning could result in bodily harm or death.

Eine Warnung enthält Informationen zur persönlichen Sicherheit. Das 
Nichtbeachten der Anweisungen in der Warnung kann zu Verletzungen 
oder zum Tod führen.

Un avertissement contient des informations relatives à la sécurité 
personnelle. Ignorer les instructions dans

l'avertissement peut entraîner des lésions corporelles ou la mort.

CAUTION A Caution contains information that the user needs to know to avoid 
damaging or permanently deleting data or causing physical damage to 
the hardware or system.

IMPORTANT An Important note is a type of note that provides information essential to 
the completion of a task or that can impact the product and its function. 

Item_name Words in this special boldface font indicate the names of buttons or 
pages found in the Web Management Interface.

Ctrl-Alt-r This type of format details the keys you press simultaneously. In this 
example, hold down the Ctrl and Alt keys and press the r key.

NOTE A Note indicates neutral or positive information that emphasizes or 
supplements important points of the main text. A note supplies 
information that may apply only in special cases, for example, memory 
limitations or details that apply to specific program versions.

Menu Flow 
Indicator (>)

Words with a greater than sign between them indicate the flow of actions 
to accomplish a task. 

For example, Setup > User > Password indicates that you should click the 
Setup tab, then the User secondary tab, and finally the Password button 
to accomplish a task.

Courier 
Italic

A variable for which you must substitute a value.

Courier Bold Commands you enter in a command-line interface (CLI).
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1
Overview

SnapStorage Manager (SSM) is a Java-based application that runs on all major client 
systems. SSM provides a single screen from which administrators can discover all 
GuardianOS SnapServers, SnapCLOUD servers, REO appliances, SnapSAN arrays, 
SnapScale clusters, and SnapScale Uninitialized nodes (that is, nodes that are not part of a 
SnapScale cluster) on their network.

Once found, an external application or browser can be used for management of the systems. 
Additionally, SSM can monitor, upgrade, restart, or shutdown one or more systems 
simultaneously.

This section is divided into sub-sections that provide the key processes and configuration 
options needed to maximize your usage of SnapStorage Manager:

Topics in Overview:

• Tips and Requirements 

• SnapStorage Manager Main Window 

Tips and Requirements
Consider the following technical tips and requirements when deploying SnapStorage Manager 
on the network.

Normalize Admin Passwords for Groups
Before you can configure a group of servers, the admin password for each server in the group 
must be entered. If the members in the group have different admin passwords, you need to 
remember and enter the password for each member. Normalizing the password for the admin 
account for each group member allows you to gain administrative access to all members in the 
group by entering just a single password.

Right-Click vs. Control-Click
This document uses the Windows convention of right-clicking in describing keyboard access to 
context-sensitive menus. Macintosh users should substitute control-click to achieve the same 
result.
10400859-001 ©2013-18 Overland Storage, Inc.   1
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SnapStorage Manager Main Window
The SnapStorage Manager main window allows an administrator instant access to all the 
supported systems on the network.

The SnapStorage Manager main screen is divided into four sections:

• Server Status Bar – Located at the top of the screen, it displays counts of online and 
offline servers. It gives a count of each type of Snap product that is online.

• Groups List – Located on the left, it provides a collapsible list of supported systems 
that can be sorted into groups for easier management.

• Details List – Located on the right, it is the main area and shows detailed information 
about each supported system.

• Operation Status Bar – Located at the bottom of the screen, it provides specific 
information about operations and transmissions (Tx /Rx).

Because it is a graphical interface, the main screen is able to convey large amounts of 
information using specialized SSM icons for each system type and their current statuses.

Groups
List 

Details List

Server Status Bar

Operation Status Bar
10400859-001 ©2013-18 Overland Storage, Inc.   2
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The Details List area contains several columns of information. Use the hidden option list 
(right-click the column header area) to make changes (see Customize the SSM Interface on 
page 12).

Server Icons
The Server column in the Details List of SnapStorage Manager has visual cues to the status 
and health of the systems on your network. The following color scheme applies to all icons you 
see on the SnapStorage Manager main window and any sub-windows that are displayed.

Status Icons
The Status column in the Details List uses the following icons to alert users to the different 
statuses on systems managed by SSM. These icons follow the usual alert color-coding and turn 
the appropriate color depending on the alert.

To check the status of a system, double-click the system name to open the Properties screen.

Server
Icon

Uninitialized
Node Icon

SnapScale
Cluster Icon

SnapCLOUD
Icon

Description

The system is online.

One or more status indicators indicate a 
warning-level condition.

One or more status indicators indicate a fault-
level condition.

The system is offline.

Icon Description

Drive Status – Indicates whether a drive error has occurred. Double-click the system name to 
check the specific problem.

All disks are OK.

A disk has a warning-level condition.
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The Details List also displays a storage usage icon that shows what percentage of the space on 
the system’s main volume is being used:

A disk has a fault-level condition or failed.

Disk status is not available (system may be offline).

Ethernet Status – Indicates whether an error has occurred with a NIC. Double-click the 
system name to check the specific problem.

All Ethernet ports are OK.

An Ethernet port has no link.

An Ethernet port has failed, or one Ethernet port in a bonded pair has no link.

NIC status is not available (system may be offline).

Power Supply Status – Indicates whether the power to the system has encountered a 
problem. Double-click the system name to check the specific problem.

All power supplies are OK.

A power supply is missing, has failed, or is not plugged in.

Power supply status is not available (system may be offline).

Fan Status – Indicates whether a fan on the system has encountered a problem. Double-click 
the system name to check the specific problem.

All fans are OK.

A fan is missing or has failed.

Fan status is not available (system may be offline).

System/CPU Temperature – Indicates whether the system or CPU temperature has changed 
to possibly harmful levels. Double-click the system name to check the specific problem.

System or CPU temperature is OK.

System or CPU temperature is high.

System or CPU temperature is critical.

Temperature status is not available (system may be offline).

Icon Description

Storage Usage – The blue bar Indicates how much of the storage space on the 
system’s volumes and iSCSI disks has been used. The numerical usage percentage 
is shown to the right. If the maximum is almost reached, the usage text is shown in 
red. Offline systems display a question mark (?).

Icon Description
10400859-001 ©2013-18 Overland Storage, Inc.   4



SnapStorage Manager Version 8.6 User Guide 1 - Overview
  
Communication Indicators
For all supported systems, the Status Bar displays two LED indicators that monitor the 
transmission of discovery packets. Discovery packets are used to monitor the status of systems 
that SSM is monitoring. The LED indicators are located at the bottom right of the screen. For 
more information about discovery packets, see System Discovery on page 8.

Software Update Notification Banner
A banner is displayed across the top of the GUI whenever OS updates are available for 
discovered systems.

NOTE: The Software Update Notification feature is enabled by default, but can be disabled from Edit 
> Options.

The Tell me more link in the banner opens the Server Software Updates dialog box, listing the 
systems for which an update is available, the current OS version each of the systems is 
running, and the updated version available for each of the systems.

Icon Description

“Tx” stands for “Transmit” and lights whenever SSM sends out a request for 
discovery information.

“Rx” stands for “Receive” and lights whenever SSM receives a discovery 
packet.

The mouseover tooltip displays the number of packets transmitted and 
received, respectively.
10400859-001 ©2013-18 Overland Storage, Inc.   5
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NOTE: You can choose to hide the banner by clicking the “Remind me later” or “Hide this message” 
link on the banner. When “Remind me later” is clicked, the system displays the banner after 
the next check for updates; when “Hide this message” is clicked, the system hides the banner 
for the specific update until a later version update is released.
10400859-001 ©2013-18 Overland Storage, Inc.   6
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SnapStorage Manager Features

SnapStorage Manager can be used to discover SnapServers, SnapCLOUD servers, REO 
appliances, SnapSAN arrays, SnapScale clusters, and SnapScale Uninitialized nodes. Status 
monitoring is available for SnapServers, SnapCLOUD servers, and Uninitialized nodes.

Topics in SnapStorage Manager Features:

• Primary Features 

• System Discovery 

• About SSM Dialog Box 

• Customize the SSM Interface 

• SnapServer/SnapCLOUD Server Administration 

Primary Features
SnapStorage Manager provides a single management interface across all of your SnapServer 
devices. The following are the main features of SSM:

• Discover Systems on the Network 

• Launch External Administration 

• Assign IP Addresses to SnapServers on a Network Without a DHCP Server 

• Monitor System Status 

• Software Update Notification 

• Multiple Server Administration 

Discover Systems on the Network
SnapStorage Manager automatically discovers all supported systems on the same network 
segment and displays them in the main SSM window. Additionally, SSM discovers systems 
outside the local network if they have been added to the Remote Servers list. For more 
information, see System Discovery on page 8.

Launch External Administration
The Web Management Interface is a browser-based application that allows you to perform a 
wide range of administrative tasks on a system-by-system basis. To launch this tool, right-
click the system name or click the name and go to Administration > Launch Web Management 
Interface.
10400859-001 ©2013-18 Overland Storage, Inc.   7
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Assign IP Addresses to SnapServers on a Network Without a DHCP Server
By default, SnapServers and Uninitialized nodes are preconfigured to use DHCP to acquire an 
IP address at startup. If a SnapServer or Uninitialized node cannot find a DHCP server on the 
network, you may not be able to access the system. SSM discovers all SnapServers, 
Uninitialized nodes, and SnapScale clusters on its local subnet using a proprietary multicast 
communication mechanism.

To set a static IP address for a specific SnapServer or Uninitialized node, right-click the 
system name in the Details List and select Set IP Address.

Monitor System Status
The color coding of system and group names alerts administrators to warning and fault 
conditions on a system. To view detailed status information, double-click anywhere in the row 
in the Details List. See Server Icons on page 3.

Software Update Notification
SnapStorage Manager is configured to check daily for available updates for both GuardianOS 
and SnapCLOUD, and to display an alert at the top of the Details List when updates are 
available.

To force SSM to check for available updates immediately, click Administration > Check for 
Server Software Updates. SSM connects to the remote software update server, searches for 
applicable updates for all of the discovered systems, and displays them in the Software 
Updates dialog box.

Multiple Server Administration
SnapStorage Manager can perform an upgrade, reboot, or shutdown on one or more servers 
simultaneously and report the status of operations. These tasks are handled by selecting 
multiple servers, logging on, and selecting the appropriate task under the Administration tab.

System Discovery
At SnapStorage Manager startup and once per minute afterward, SSM broadcasts a discovery 
request packet to its local subnet. Supported systems on the same network segment that 
receive discovery requests respond with a discovery packet containing information. All other 
discovery activity is performed using both direct communication (unicast) and a proprietary 
multicast communication mechanism that does not impact other systems on the network.

When SSM sends or receives discovery packets, status LEDs at the right on the Status Bar 
flash according to which activity is taking place. The LED labeled “Tx” flashes whenever SSM 
sends out a discovery request. The LED labeled “Rx” flashes whenever SSM receives a system 
discovery information packet.

You can add other supported systems that reside outside the local network segment by 
entering their IP addresses in the Remote Server List (Edit > Remote Servers). This includes 
SnapServers, SnapCLOUD servers, and Uninitialized nodes.

NOTE: SnapCLOUD servers can only be discovered via the Remote Server List.
10400859-001 ©2013-18 Overland Storage, Inc.   8
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If SSM has not been able to communicate with a discovered system (for example, the system is 
offline or has just been started), that system’s IP address appears in blue and the Properties 
screen for that system shows Not Validated next to the IP address. Once SSM has successfully 
communicated with the system, the text color of the IP address changes to black, and 
Validated appears on the Properties screen.

Local Discovery
A local system is one that resides on the same network segment as the machine on which 
SnapStorage Manager is installed. Overland systems regularly send Multicast discovery 
information to their local network segment, other systems broadcast their presence once on 
startup, and all systems respond to discovery request broadcasts from SSM. SSM passively 
listens for Multicast or broadcast discovery information from supported systems and 
broadcasts a discovery request packet on the local network segment in three cases: (1) at 
startup; (2) once per minute; and (3) when the administrator manually refreshes the 
information by selecting Edit > Refresh All.

NOTE: SnapCLOUD servers cannot be discovered via local discovery and must be discovered via the 
Remote Server List.

Remote Discovery
A remote system is one that resides on a network segment different than the one on which 
SnapStorage Manager resides. SSM cannot hear discovery information broadcasts from 
remote systems until the administrator configures them on the Remote Servers list (see 
Configure Remote System Discovery Example on page 9). 

SSM regularly queries SnapServers and SnapCLOUD systems on the Remote Servers list for 
discovery information. When discovered, remote systems return information about themselves 
and any other GuardianOS and SnapCLOUD systems they've discovered themselves on their 
local networks or through their own Snap Finder remote server lists. As a result, only one 
SnapServer or SnapCLOUD system needs to be added to the Remote Servers list per remote 
network to discover all remote SnapServers and SnapCLOUD systems on that network.

However, for systems not running SnapServers and SnapCLOUD systems, each system must 
be added individually to the Remote Servers list. Remote systems discovered in this manner 
display the letter R in the Discovery State column of the Details List of the SSM screen, along 
with the name of the discovering remote system, if applicable.

• You can add a SnapCLOUD server’s external IP address (VIP) or global DNS name (if 
configured) if inbound ports UDP/2599 and TCP/9050 are enabled on the server's 
network security rules.

• You can add a SnapCLOUD server’s internal IP address or internal DNS name (if 
configured) if its virtual network is accessible via site-to-site or client-to-site VPN.

NOTE: For instructions on displaying the Discover State column in the SSM screen, see Details List 
on page 13.

Configure Remote System Discovery Example

For example, assume a remote network segment contains six systems:

• REO 4600 running the latest REO 4600 GUI (non-GuardianOS)

• SnapServer DX2 running GuardianOS 7.2

• SnapSAN S2000 running SnapSAN 4.3 GUI (non-GuardianOS)

• SnapServer 410 running GuardianOS 5.2
10400859-001 ©2013-18 Overland Storage, Inc.   9
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• SnapServer N2000 running GuardianOS 6.5

• SnapScale Cluster running RAINcloudOS 3.0

To enable SnapStorage Manager to discover all these remote systems, the IP address of just 
one SnapServer, SnapCLOUD server, or RAINcloudOS node/cluster needs to be entered in the 
Remote Servers list to discover all other GuardianOS-, SnapCLOUD-, and 
RAINcloudOS-based systems on the remote network segment. The systems not running 
GuardianOS, SnapCLOUD, or RAINcloudOS must be manually added. Using a SnapServer, 
SnapCLOUD server, or RAINcloudOS node/cluster as a remote discovery system makes the 
administrator’s configuration task easier and reduces the network traffic required to refresh 
system status.

NOTE: SnapCLOUD servers on Microsoft Azure cannot discover other SnapCLOUD servers on its 
virtual network via Snap Finder, so those must be manually added.

For full interoperability, it is recommended that all SnapServers, SnapCLOUD servers, and 
SnapScale clusters/nodes on the network run the same version of the system software. If you 
have systems running different versions of the software on your network, use a system 
running the most current version as the remote discovery server/cluster/node.

Laptop SSM Installation and Remote System Discovery
Unexpected results may occur in instances where SnapStorage Manager is installed on a 
laptop that is moved from one network segment to another. In this situation, the systems that 
were previously in SSM’s local segment are now in a remote segment, and since no remote 
system has been designated in that segment, SSM can no longer hear their discovery 
information broadcasts. Thus, when SSM is started up in the new location, these systems will 
display as offline.

Ensure All Systems Display Correctly in the SSM Screen

SnapStorage Manager offers three methods to ensure all systems display correctly in the SSM 
screen. The first option is the preferred method (available only if all systems are GuardianOS 
servers, RAINcloudOS nodes/clusters, and SnapCLOUD servers) because this method results 
in less network traffic than the other options; but any combination of methods can be used to 
suit your environment.

Procedure Result

Add one GuardianOS (v. 2.6 or higher) server, SnapCLOUD 
server*, or RAINcloudOS node/cluster from every network 
segment (including the current local segment) to the 
Remote Servers List.

This option is applicable only if all servers/nodes/clusters 
on the remote network are GuardianOS servers, 
SnapCLOUD servers, or RAINcloudOS nodes/clusters.

SSM sends out only a single DRP 
for each system on the Remote 
Servers List.

For other systems, manually add each system to the 
Remote Servers List.

SSM sends out a single DRP for 
each system on the Remote 
Servers List.

From SSM, select Edit > Options. Select the Auto-scan 
servers not on Remote Server list option, and click OK. 

This option instructs SSM to directly (and regularly) send 
DRPs to all previously discovered systems that are neither: 
(1) specified on the Remote Servers list, nor (2) resident on 
the same network segment as a system specified on the 
Remote Servers list.

SSM sends out one DRP for each 
previously discovered system, 
resulting in increased network 
traffic.
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About SSM Dialog Box
To access the About information box in SSM, select Help > About SnapStorage Manager.

This dialog box provides the following information:

• SSM version number

• Related GuardianOS version number

• Contact information (phone and website)

• System Properties for the computer on which SSM is running

Click OK to clear.

* Adding a SnapCLOUD virtual machine to the remote server list will only discover the remote servers the 
SnapCLOUD server itself is configured for.
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Customize the SSM Interface
At startup, the SnapStorage Manager displays all Overland systems discovered on the local 
subnet as well as any remote supported systems manually configured by the administrator. 
The default group <All Servers> contains all the discovered systems. Additional groups can be 
created for easier administration.

The Operation Status Bar at the bottom shows the status of any running or scheduled 
operations. Operations are defined as administrative tasks (for example, OS update or system 
restart) that are run concurrently.

Groups
SnapStorage Manager allows administrators to organize systems into groups for ease of 
administration. Different groupings can be created, saved, and shared with other 
administrators. Clicking a group name or folder icon displays only the group’s members in the 
Details List. Clicking the toggle to the left of the group folder icon shows all the systems under 
the name. Clicking it a second time closes the list.

Group Color Coding

The folder color of a group reflects the highest level of alert for any of the systems in the group.

NOTE: Only SnapServers, SnapCLOUD servers, or RAINcloudOS nodes/clusters display the warning 
and failure color codes. A group with only non-GuardianOS/SnapCLOUD/RAINcloudOS 
systems will be color-coded in blue.

Create, Populate, and Maintain Groups

Use either the context menu (right-click a group name) or, with a group name selected, use the 
Edit menu options to make changes. The active options change based on which item in the list 
is clicked.
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In creating groups, you can perform the following operations:

Save and Distribute Groups

Administrators who manage systems from different machines may want to have the same 
group structures available from each SSM installation. Groups can be saved to an XML file by 
highlighting the group and selecting File > Save Groups As. By default, this file is saved to the 
home directory for your system.

For example, on a Windows machine, the location of the XML file in the default home 
directory would be similar to the following:

C:\Documents and Settings\username\ssm_groups.xml

To share groups, copy the XML files to an appropriate directory on any other machines used to 
manage systems. Alternatively, you can select File > Open Groups and navigate to the desired 
file.

Remove Offline Systems

Select Edit > Remove Offline Servers to remove offline systems from groups. An Include all 
subgroups check box on the Confirmation dialog allows you to remove offline systems from the 
subgroups of the selected group also. The subgroup removal option is checked by default and 
is disabled (grayed) if the selected group has no subgroups.

Details List
The data displayed in the Details List can be customized to accommodate different 
administrative interests.

Column Definitions

The Details List is divided into several different columns. Use the hidden menu (right-click 
the column heading area) to add or delete columns. The following table defines the properties 
shown in these columns:

Task Procedure

To create a new group on 
the root

Right-click the Servers & Groups top level and select New Group. Enter a 
unique name in the dialog box that opens and click OK. The new group is 
added alphabetically to the root of the Groups List tree.

To create a new group 
inside another group

Right-click a group name and select New Group. Enter a unique name in 
the dialog box that opens and click OK. The new group is nested inside 
the original group.

To copy multiple systems 
from the Details List to a 
group

Select one or more system names from the Details list, and do one of 
the following:
• Right-click one of the highlighted rows and select Copy. Select a group, 

then right-click and select Paste.
• Click-and-drag one of the selected highlighted rows to the group.

To copy the contents of 
one group into another 
group

Right-click a group and select Copy. Then, right-click the target group 
and select Paste.

To rename a group Right-click a group and then select Rename Group. Enter a unique name 
in the dialog box that opens, and click OK.

To delete a group Right-click a group and then select Delete. In the confirmation dialog box 
that opens, click Yes.
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Customize the Details List

Use the following procedures to customize the information displayed in the Details List:

Column Description

Server Lists the names of all discovered systems (servers, 
appliances, arrays, nodes, and clusters).

Status (icon on left) • OK – All systems are functioning correctly (blue).
• Offline – The system is offline (gray).
• Alert Icon – Displays any warning (yellow) or fault (red) 

conditions for the selected SnapServer, SnapCLOUD 
server, or RAINcloudOS node/cluster. See Status Icons on 
page 3 for a list and description of the different icons.

IP Address Displays the IP address and type (DHCP or Static) for the 
system.

Model Displays the type of system hardware (such as XSR120 or 
DX2)

OS Version Displays the OS type (GOS, REO, SAN, ROS, or SnapCLOUD) 
and version number.

Storage Usage Shows a percentage bar and the numerical percentage of the 
amount of storage space used.

OS*

* These columns not shown in the default display. Must be added manually using the right-click menu.

Displays the operating system name of the system.

Number* Displays the unique server number of the selected system.

Up-Time (D:H:M)* Displays how long a system has been up and running, in 
days, hours, and minutes.

Discovery State* Displays the date and time the listed system’s DRP was 
received by SSM.

Configured* Displays whether or not the system has gone through the 
initial configuration process. Displays yes, no, and partial.

Expansion Systems* Displays the number and type of expansion units attached to 
a system.

Snap ECR* Displays the Snap Encrypted Continuous Replication™ 
version supported. S: (sources supported) and T: (targets 
supported).

Task Description

To sort the Details List 
according to a column

Click a column header. The Details List sorts according to the 
contents of the column in ascending order. To sort in 
descending order, click the column header again.

To resize a column header Hover the cursor over the right border of the column header 
you want to resize until the double-headed arrow appears, 
and then click and drag the border to the desired width.

To normalize the size and 
contents of all column 
headers

Right-click any column header and click Reset Columns. The 
original factory set columns, properties, and order are 
restored.
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SnapServer/SnapCLOUD Server Administration
From the SnapStorage Manager menu, select Administration > Administer Servers. You are 
prompted to enter the user name and password.

NOTE: A password must be set on the “admin” user to perform many of the following operations on 
SnapCLOUD servers.

If servers within a group have different passwords, you will have to remember and enter each 
password before you can administer the group. For ease of administration, configure servers 
within a group with the same password.

Tip: Configure the servers within a group with the same password to access them easily.

Three administrative tasks are listed in the left-hand pane:

• OS Update (need to enter the OS file by browsing)

• Restart 

• Shutdown 

Select an option and click Apply. The interface provides feedback on the progress.

To load a different property 
into a column

Right-click a column and select a different property.

To create a new column Right-click a column, and select New Column. The clicked 
column is duplicated. Right-click the new column, and select 
a different property (see “Column Definitions”).

To delete a column Right-click a column header and select Delete Column. 

Task Description
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3
SSM Dialog Boxes Reference

This section describes some of the SnapStorage Manager dialog boxes and their usage 
associated with the Edit and Administration menu options:

Edit Menu Dialog Boxes:

While most options have simple dialog boxes, the following Edit menu items have additional 
options in their dialog boxes:

• (Server) Properties 

• Remote Servers 

• Options 

Administration Menu Dialog Boxes:

These special Administration menu and sub-menu options apply to SnapServers and 
SnapCLOUD servers only:

• Administering Servers 

• OS Update 

• Restart 

• Shutdown 

• Apply to Servers Dialog Box 

• Launch Web Management Interface 

• Set IP Address (includes Uninitialized nodes)

• Wake Up Servers 

• Feature Licensing 

• Check for Server Software Updates 
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(Server) Properties
The Server Properties dialog box (select Edit > Properties or right-click the server name) 
provides a summary of system specifications and status data.

Graphic Indicators (GuardianOS only)
In the Status section of the dialog box, icons on the left of the list of items provide a quick 
visual status indicator. See Server Icons on page 3 and Status Icons on page 4 for details.

Discovery IP Address
The text (Discovery) is placed next to the IP address used to discover the system. See Discover 
Systems on the Network on page 7.

Total Storage Usage (GuardianOS/SnapCLOUD/RAINcloudOS only)
For SnapServers and SnapCLOUD servers, the percentage refers only to capacity that has 
been allocated to existing volumes and iSCSI disks; unallocated RAID capacity is not included. 
For RAINcloudOS clusters, the percentage refers to the storage usage of the entire cluster. See 
Communication Indicators on page 5.

Remote Servers
Select Edit > Remote Servers to open a dialog box used to add systems that reside outside the 
network segment on which SnapStorage Manager resides. See Discover Systems on the 
Network on page 7.
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The options in this dialog box are covered in detail in the following sections.

Add Remote Systems
Enter the system’s IP address, fully-qualified name, or server/cluster name in the New Remote 
Server field and click Add.

• If you entered the IP address, it appears in the Remote Servers list, with the system 
name in parentheses (if resolved).

• If you entered the server/cluster name, it appears in the Remote Servers list, with the IP 
address in parentheses (if resolved).

• If SSM cannot find the remote system you entered, unresolved appears in the Remote 
Servers list after the name or IP address.

• You can add a SnapCLOUD server’s external IP address (VIP) or global DNS name (if 
configured) if inbound ports UDP/2599 and TCP/9050 are enabled on the VM's network 
security rules.

• You can add a SnapCLOUD server’s internal IP address or internal DNS name (if 
configured) if its virtual network is accessible via site-to-site or client-to-site VPN.

The current number of remote servers/clusters is listed above the Remote Servers list. The 
maximum allowed remote servers/clusters is 5000.

Delete a Remote System

NOTE: The servers will be deleted immediately without requiring a confirmation.

In the Remote Servers list, select one or more remote systems and click Delete.

Adjust the Remote System Refresh Interval
Adjust the refresh interval to a setting between 30 and 90 seconds.

Toggle Discovery of Remote Systems
Click the Enable discovery of remote servers check box to turn the discovery of remote servers 
ON/OFF.
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Import a Remote Server List
Remote server/cluster names and/or IP addresses can be imported from a text file. Within the 
text file, each system and IP address can be designated either by entering one system per line, 
or by entering multiple names separated by a space, a comma, or a semi-colon. Blank lines and 
lines beginning with the number sign (#) are ignored.

NOTE: If the remote systems are being imported and would make the Remote Servers list greater 
than 5000 systems, SSM displays a prompt to truncate the list being imported.

To import a list, click the Import button, navigate to the appropriate text file, and click OK.

The remote servers list will be added to the existing list, ignoring duplicate systems.

Options
Clicking Edit > Options opens a dialog box that allows for the configuration of SnapStorage 
Manager general options.

The configurable SSM options let you:

• Specify and test the Web browser that SSM uses.

• Set the period (in seconds) following the receipt of the last discovery packet after which 
a system will then be considered offline.

• Specify whether SSM displays a warning if any Ethernet port does not have a link 
(GuardianOS and RAINcloudOS only).

• Instruct SSM to directly scan all systems including those not on the Remote Server list.

• Configure an HTTP proxy server to access the Internet by entering a proxy host and 
proxy port.

• Enable/disable automatic notification of OS updates (SnapServers and SnapCLOUD 
servers only).

Specify a Web Browser
You can specify the Web browser you would like SnapStorage Manager to use to display the 
Web Management Interface and the SSM online help system.

• Click Browse to navigate to and select the executable for your chosen browser.

• Click Test to open the Overland Storage Customer Support page in your chosen browser.
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Adjust the System Offline Timeout Setting
SSM constantly updates the Device List with fresh data it receives from systems that reside 
on its local network segment and are specified on the Remote Servers list. SSM considers a 
system offline if no communication occurs for the specified timeout period. (The default 
timeout period is 180 seconds.) If SSM receives no communication from a system during the 
timeout period, it displays that system as offline in the Details List of the main SSM screen. 
Adjust this interval to a setting between 120 and 300 seconds as appropriate for your network 
conditions.

Display No-Link Status Warnings for Ethernet Ports

NOTE: Applies to GuardianOS and RAINcloudOS only.

SSM is set by default to display a warning status if one of a system’s Ethernet ports has no 
link. With this feature activated, you can quickly see all systems with no-link status Ethernet 
ports (such as, unplugged Ethernet cables). You may wish to disable the no-link status feature 
if you have systems with only one connected Ethernet port. To disable the feature, uncheck the 
Display warning if any of a server’s Ethernet ports has no link check box, and click OK.

Activate Auto-scanning of All Remote Systems
When SnapStorage Manager is installed on a laptop that is moved from one network segment 
to another, some remote systems may appear to be offline when they are in fact online. The 
Auto-scan servers not on Remote Servers list option ensures that discovery works properly by 
sending discovery request packets to each system discovered in a previous session; this 
solution does, however, increase network traffic. To activate auto-scanning, select the check 
box and click OK.

Use an HTTP Proxy Server
In environments that use an HTTP proxy server to access the Internet, SSM must be 
configured to use the proxy for update notification or accessing the web online help. Check Use 
a proxy server for HTTP communication, enter the name or IP address of the proxy server in the 
Proxy host field, and enter the port used by the proxy server in the Proxy port field.

Enable Automatic Update Notification

NOTE: This feature is only available for SnapServer and SnapCLOUD servers.

SSM is configured by default to check daily for available updates to SnapServer and 
SnapCLOUD servers. When an update is found for discovered servers, an alert displays in a 
banner at the top of the SSM main window. The Tell me more link in the banner opens the 
Software Updates dialog, listing systems for which an update is available, the version of OS 
each system is currently running, and the version of the update available.

NOTE: You can choose to hide the banner by clicking the Remind me later or Hide this message link 
on the banner. When Remind me later is clicked, the system displays the banner after the 
next check for updates; when Hide this message is clicked, the system hides the banner for 
the specific update until a later version is released.

To disable this feature, uncheck the Enable Automatic Update Notification check box and click 
OK.
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Administering Servers
This dialog box is the starting point for updating the OS, restarting, and shutting down 
GuardianOS and SnapCLOUD servers.

To launch this feature:

1. Select one or more servers from the Details List.

2. Select Administration > Administer Servers.

3. At the Login dialog box, enter the User Name and Password for each server.

If more than one server uses the same User Name and Password, you only have to enter 
the information once. All similar configured servers will automatically be logged into.

4. Choose the option you want to use:

• OS Update 

• Restart 

• Shutdown 

OS Update
1. In the left column, verify that the default OS Update option is selected.

2. Browse to where the latest OS update file has been saved.

If you haven’t downloaded the OS update yet, use the blue web link to access the 
downloadable file.

3. Select the update file and click Apply.

4. At the Apply to Server dialog box, choose the options desired.

See Apply to Servers Dialog Box for details about the options.

The selected servers are updated.

Restart
1. In the left column, click Restart and then click Apply.

2. At the Apply to Server dialog box, choose the options desired.

See Apply to Servers Dialog Box for details about the options.

The selected servers are restarted.
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Shutdown
1. In the left column, click Shutdown and then click Apply.

2. At the Apply to Server dialog box, choose the options desired.

See Apply to Servers Dialog Box for details about the options.

The selected servers are shut down.

Apply to Servers Dialog Box
When administering GuardianOS or SnapCLOUD server settings (see Administering Servers 
on page 21), clicking Apply opens this dialog box. It lists operations to be performed on a group 
of GuardianOS and SnapCLOUD servers. 

• Start Now – Applies the chosen option immediately. The interface informs you of the 
progress (via a progress bar) and result of the operations.

• Start Later – An Apply Schedule dialog box opens to select the date and time to apply this 
option. Click OK to schedule the event.

NOTE: The status bar in the main screen displays the status of the scheduled operations. While 
operations are scheduled to run, no other multiserver administration is possible.

To cancel the schedule before it occurs, repeat the steps and click Stop in the Apply to 
Servers dialog box. Click Yes to confirm the cancellation,

• Report – This opens the Operations Report dialog box.

Do one of the following:
10400859-001 ©2013-18 Overland Storage, Inc.   22



SnapStorage Manager Version 8.6 User Guide 3 - SSM Dialog Boxes Reference
  
• To set up the email report delivery for this and all future operations, complete the 
fields provided and click OK.

• To save an operations report for the completed operation, click Save Report. The 
report will be saved as a CSV file to a location of your choice.

Improve the Readability of the Display

When working with a large number of settings or servers, use the following methods to 
improve the readability of the display.

Launch Web Management Interface
When only one system is selected in the Details List, this option can be used to launch the Web 
Management Interface for that server.

Set IP Address
NOTE: Set IP Address is only available for SnapServers and Uninitialized nodes that are configured 

for DHCP and have not received an IP address from a DHCP server.

By default, SnapServers and Uninitialized nodes are preconfigured to use DHCP to acquire an 
IP address at startup. If a Uninitialized node cannot find a DHCP server on the network, it 
will default to a “ZeroConf” IP address (169.254.*.*) and you may not be able to see the server 
on your network. In this case, Set IP Address can be used to assign a fixed (static) IP address to 
the server. 

NOTE: Servers running GuardianOS 6.0 and earlier versions will show 10.10.10.10 as the IP address 
in this case rather than a ZeroConf address.

Set a Server’s or Uninitialized Node’s IP Address
1. In the SSM main screen, select a server/uninitialized node.

2. Right-click the server/node, and select Set IP Address.

3. Enter the IP address and subnet mask in the TCP/IP Addressing fields.

Optionally, you may also specify the default gateway, domain name server, domain 
name, and WINS server as appropriate.

Method Description

Fit Columns in Display When selected (default), this option resizes column widths to 
fit in the current size of the window. All columns are visible, but 
text within columns may be clipped.

When deselected, column widths expand to fit the width of its 
contents, but some columns may not be visible.

Resizing columns To resize a column, hover the cursor over the border between 
column headers, and then click and drag to the desired width
10400859-001 ©2013-18 Overland Storage, Inc.   23



SnapStorage Manager Version 8.6 User Guide 3 - SSM Dialog Boxes Reference
  
Wake Up Servers
Use this feature to wake up one or more servers that are sleeping.

Feature Licensing
Select Administration > Feature Licensing to apply SnapExtension license keys to one or more 
SnapServer and SnapCLOUD servers. There is no limit to the number of licenses that can be 
entered using this dialog box. Click Enter License, then enter one or more license keys per line 
(or separated by spaces), and click OK. This feature is only available with GuardianOS v 4.0 or 
later and SnapCLOUD.

The Feature License dialog box does not display any pre-existing SnapExtension licenses. 
Only licenses that have been applied while the current dialog box is open will be displayed.

Check for Server Software Updates
When you select Administration > Check for Server Software Updates, the SnapStorage Manager 
connects with a remote server to determine if any of SnapServers or SnapCLOUD servers it is 
monitoring have new software updates available.
10400859-001 ©2013-18 Overland Storage, Inc.   24



SnapStorage Manager Version 8.6 User Guide 3 - SSM Dialog Boxes Reference
  
The resulting dialog box lists all of the systems that SSM has discovered that have updates 
available, and provides the following information about the systems:

Apply Software Updates

1. To download the available OS update, click the Download this software at: web link.

2. Apply the software update.

For SnapServer and SnapCLOUD servers, SSM creates a special SSM Server Group in 
the left panel called <Updates Available>. It contains all the systems for which each 
update is applicable. Multiple OS updates may be possible for a given server. Apply the 
software update to the systems in this folder following the normal update procedure.

Property Description

Server Name Name of the system that has an update available.

Current OS version Version of the OS currently running on the system.

Update OS versions Most recent version of the OS to which the system can be updated.
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